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1 RT-Druid and Erika Enterprise tutorial for dsPIC
(R) DSC

This small tutorial describes a set of steps needed to compile a simple application that
shows the main features of Erika Enterprise and RT-Druid for the dsPIC (R) DSC platform.

This tutorial has been tested on a FLEX board produced by Evidence and Embedded
Solutions and on a Microchip Explorer 16 development board from Microchip.

We suppose the reader is familiar with the MPLAB IDE debug environment provided
by Microchip.
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2 Notes for Windows XP and Windows Vista

users

If you are using Windows, and especially if you are using Windows Vista, please look
carefully at the following warnings:

Warning: Do NOT install the Evidence package in a name containing spaces.
c:/Evidence/Evidence works.

Warning: Do NOT install the Scilab package in a name containing spaces.
c:/Evidence/scilab-4.1.2 works.

Warning: If using Vista, be aware that directories like c:/Programmi,
c:/Users/Documenti are not REAL directories but are aliases. DO NOT USE THEM.
Put your RT-Druid workspace under c:/Users/yourusername/workspace.

Warning: Please install cygwin into its default directory, c:/cygwin.

Warning: Also if from the Windows Vista Explorer your Microchip compiler
seems to be installed under c:/Programmi/Microchip/..., please remind to specify
the REAL pathmname. In particular, c:/Programmi DOES NOT EXISTS, whereas
the correct name is c:/Program Files.
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3 Installing Erika Enterprise and RT-Druid on

Microsoft Windows

This chapter will guide the developer to the installation procedure of Erika Enterprise
and RT-Druid for the dsPIC (R) DSC platform.

The installation of Erika Enterprise and RT-Druid is composed by the following pack-
ages:

• The Eclipse development environment, which is used by RT-Druid to provide the
basic development environment for Erika Enterprise applications.

• The Eclipse environment is based on the Java platform, so that a working Java
Runtime Environment must be present for using RT-Druid.

• The RT-Druid plugins, which provide the code generation for Erika Enterprise for
Eclipse.

• The Erika Enterprise source code.

• The Microchip MPLAB IDE.

• The Microchip C30 Compiler.

• A version of the Microchip C30 compiler recompiled from the GCC sources, which
enables basic C language compilation without the need to buy the full fledged
Microchip C30 Compiler.

• A set of examples for the dsPIC (R) DSC Platform, which can be used to compile
a first set of running examples for the Evidence/Embedded Solutions FLEX board,
the Microchip Explorer 16 board, and others. These applications are organized in
“templates”, available at project creation.

• A subset of the Cygwin environment [1], including a set of utilities like make, gawk,
and few others, which are used during the compilation process of an Erika Enterprise
application.

To install the software, execute the following steps:

1. Install your favourite Java runtime environment, which is needed to run RT-Druid;
in fact, RT-Druid is a plugin of the Eclipse editor, which requires Java to be
executed.
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3 Installing Erika Enterprise and RT-Druid on Microsoft Windows

2. Install the latest version of the Microchip MPLAB IDE; you can use the default
install directory. At the end of the install process, accept the system reboot.

3. Install the Microchip C30 Compiler, available from the Microchip web site. Even
in this case, you can use the default install directory. When it is asked to change
the default environment, please do accept.

4. Run the Erika Enterprise and RT-Druid installer.

5. The installer will prompt a list of packages which can be installed. Select all the
packages you wish to install and continue the installation procedure (see Figure
3.1).

Figure 3.1: This screenshot shows the dialog box with the available install packages.

Note: The Erika Enterprise install package provides a version of the Microchip
C30 compiler recompiled from the GCC sources made available from Microchip.
Although that compiler is able to compile Erika Enterprise applications, it does
not include Microchip include files and libraries which are only distributed with
the Microchip package.

6. The installer will ask for a destination directory. If possible, please use c:/Evidence/Evidence
(see Figure 3.2).

7. At this point, please check the first line of the file evidencedir\bin\mymake_cygwin.bat
(where evidencedir is the directory you chose during the installation). For exam-
ple, if Cygwin is installed inside C:\cygwin, then the first line of the file should
look like the following one:

@set EE_BASH_PATH=C:\ cygwin\bin\bash
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3 Installing Erika Enterprise and RT-Druid on Microsoft Windows

Figure 3.2: This screenshot shows the preferred destination dir for installing Erika
Enterprise.

...that is, the line contains the correct path to the bash.exe file in your Cygwin
installation. If you accepted the default settings, the correct pathname should be
C:\cygwin\bin\bash as specified in the example before.

Note: We ask to perform this check because it seems that on some Windows
machines the Cygwin installer does not correctly set the registry keys used by
the Erika Enterprise installer.

The rest of this tutorial supposes that the Microchip MPLAB IDE is installed within
the C:\Programmi\Microchip directory and that, consequently, the GNU Assembler
for dsPIC (R) DSC is installed within C:\Programmi\Microchip\MPLAB ASM30 Suite\bin.
Please note that these values may be different from the settings you have chosen on your
machine. Please also read the chapter with the Windows Vista recommendations.
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4 First RT-Druid startup and configuration

After all the required packages have been installed, you are ready to start RT-Druid for
the first time.

Please follow the next steps:

1. As the first step, run the Eclipse IDE from the Evidence menu inside the Start
menu of your Windows machine, choosing Start/Programs/Evidence/RT-Druid.

2. A dialog box will appear, asking to choose the right workspace (see Figure 4.1).
Leave the default workpackage directory as it is, and proceed by pressing “OK”.

Figure 4.1: This screenshot shows the dialog box for the choice of the current workspace
directory.

Warning: The workspace pathname MUST NOT contain any blank space,
otherwise Erika Enterprise and RT-Druid may not work properly.

Note: If you are using Windows Vista, then the workspace directory
c:/Users/<username>/workspace works.

3. The Eclipse Welcome screen appears, like in Figure 4.2.

4. Before being able to correctly build your application, you should set the path to
the Microchip C30 compiler and the MPLAB ASM30 assembler programs. For
doing so, please go to the “Preference” menu, as shown in Figure 4.3, and find
the “RT-Druid/Oil/PIC30 Configurator” form as depicted in Figure 4.4. The first
textbox, labeled Gcc path, refers to the installation directory of the Microchip C30
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4 First RT-Druid startup and configuration

Figure 4.2: The Eclipse Welcome screen.

compiler. The second textbox, labeled Asm path, refers to the installation directory
of the ASM30 assembler provided with the MPLAB IDE.

Warning: The install directories specified in the two textboxes of Figure 4.4
does not include the bin directory!

That is, c:\Programmi\Microchip\MPLAB C30 is correct, wheras
c:\Programmi\Microchip\MPLAB C30\bin is not.

Warning: The install directory of the assembler refers to the assembler pro-
vided with MPLAB IDE and not the assembler provided with the C30 com-
piler. The reason is that the directory is used to call the assembler and also

to copy the crt0.s file, which has a different position in the two assemblers
distributions made by Microchip.

Warning: If you are using a Student Editon of the Microchip C30 compiler
which has an expired license, please check the “Use EE gcc to resolve depen-
dencies” checkbox in Figure 4.4.
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4 First RT-Druid startup and configuration

Figure 4.3: Go to the “Preference” menu.

Figure 4.4: Select paths for compiler and assembler.

5. Before creating and building your application, please deselect the “Build Auto-
matically” flag inside the “Project” menu, as shown in Figure 4.5.
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4 First RT-Druid startup and configuration

Figure 4.5: Deselect the “Build Automatically” flag in the “Project” menu.
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5 Compiling your first Erika Enterprise demo for

dsPIC (R) DSC

You are now ready to compile your first Erika Enterprise demo. Please execute the
following steps:

1. Please select “New Project”, then “RT-Druid Oil and c/c++ Project” from the
“File menu”, as in Figure 5.1.

Figure 5.1: Select “New project” from the “File” menu.

2. A Dialog box appear. Please select a template for the new project, as in Figure
5.2.

3. Press “Next”.

4. Insert the name of the new project. Please type taskdemo (you can choose other
names of course). Please see Figure 5.3. Press the “Finish” button.
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5 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 5.2: Select a template for your project.

Figure 5.3: Type a name for the new project.

5. We are now ready to build the demo. Right click on the project name in the
Eclipse navigation bar, and choose “Build Project”1 (see Figure 5.4).

6. Then, the compilation process starts as depicted in Figure 5.5. Please note the
message that appears when the compilation is successfull.

Note: If the error depicted in Figure 5.6 appears (meaning that
mymake_cygwin.bat is unable to find a file), then please follow the instructions
at the last point of Chapter 3.

1“Build Project” only appears if the “Build Automatically” flag is not selected in the “Project” menu.
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5 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 5.4: We are now able to build the project.

7. At the end of the compiling process you will be able to find a file named ‘pic30.cof
inside the Debug directory inside the project, as shown in Figure 5.7.

8. You are now ready to import the produced COFF file inside Microchip MPLAB
IDE. To do that, open MPLAB IDE as in Figure 5.8.

9. Choose “Import...” from the “File” menu, as in Figure 5.9.

10. A dialog box appear. Please select the pic30.cof file that has been produced by the
compilation process in Eclipse, as shown in Figure 5.10. You can find that file inside
the Eclipse workspace you selected at the beginning in Figure 4.1. In this example,
the file is stored inside the directory c:\Programmi\Evidence\eclipse\workspace\

pic30_oo_mono\Debug.

11. You have now imported the COFF file inside MPLAB IDE. There is no need
to create a MPLAB IDE Project, because the compilation process is handled by
Eclipse. Figure 5.11 shows the “Disassembly Listing” and the “Program Memory”
window. Please note that MPLAB IDE correctly recognizes the debug symbols of
the source code produced inside Eclipse.

12. You can now start debugging the demo application using MPLAB IDE.

Figure 5.12 shows the Explorer 16 board with the running pic30\explorer16\Devices Demo

demo application, which uses the Explorer 16 onboard devices to monitor and display
the environment temperature.
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5 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 5.5: The compilation process.

Note: If you get an MPLAB IDE error like the following:

ICDWarn0015: Program memory has changed since

last program operation?

Continue with Debug operation?

Running Target

ICD0083: Debug: Unable to enter debug mode.

Please double click this

message for more information.

Figure 5.6: An error that shows up on some Windows machines. Please check the
mymake_cygwin.bat file as explained in the last point of Chapter 3.
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5 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 5.7: The output file is ready to be programmed on the target board.

Please be sure that you entered the debug mode and programmed the device from

the Debugger Mode and not from the Programmer Mode.

Note: If you are using a FLEX board, please remember to set the device correctly
uinder the “Configure / Select device...” menu of MPLABIDE.

The correct settings for the dsPIC on the FLEX Full and the FLEX Light is shown
in Figure 5.13. The correct settings for the PIC18 on the FLEX Full is shown in
Figure 5.14.
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5 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 5.8: The Microchip MPLAB IDE.

Figure 5.9: Choose “Import...” from the “File” menu to import the coff file produced in
Eclipse.
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5 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 5.10: Select the COFF file you want to import.

Figure 5.11: Debug symbols are correctly recognized.
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5 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 5.12: The Explorer 16 board with the running demo program.

Figure 5.13: Selecting the dsPIC MCU mounted on the FLEX boards.
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5 Compiling your first Erika Enterprise demo for dsPIC (R) DSC

Figure 5.14: Selecting the PIC18 MCU mounted on the FLEX Full boards.

21



6 History

Version Comment

1.0.0 Initial revision.
1.1.0 Updated with information and screenshots about Erika Enterprise

version 1.4.
1.1.3 Updated with new screenshots about configuration; added warn-

ings about blanks in pathnames.
1.1.4 Added some changes to the install instructions from comments by

Simone Mannori.
1.1.5 Added Cygwin error workaround when the installer can not find

the cygwin registry value.
1.1.6 Typos found when translating the document in italian.
1.1.7 Updated some figures Figure, added a few warning boxes.
1.1.8 Added notes about MPLAB IDE.
1.1.9 Added recommendations for Windows Vista.
1.1.10 Updated screenshots for EE 1.4.3. Erika Enterprise Basic renamed

to Erika Enterprise.
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