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About this document

This document explains how to use the Evelin SDK development environment.

Function of the document

The function of this document is to provide information about the usage of the environ-

ment to developers who are going to use it.
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1 Introduction

This manual contains the instructions for the installation and the usage of Evelin SDK.

Evelin (which stands for “EVidence Embedded LINux”) is the suite of tools for embedded

Linux systems created and maintained by Evidence S.r.l..

1.1 Description of the SDK

Evelin SDK is based on the Scratchbox2 [2] environment.

Scratchbox2 is a very powerful environment that allows to develop target binaries in

a way completely transparent to the developer. In particular, Scratchbox2 is a cross-

compilation toolkit developed by the Open Source community and designed to make

embedded Linux application development easier. It provides a full set of tools to inte-

grate and cross-compile an entire Linux distribution. Once the target has been chosen,

Scratchbox2 allows to configure and compile the binaries regardless of the target ma-

chine and without worrying about cross compilation. This way, even the higher level

software based on GNU Autotools is capable of compiling transparently.

Evelin SDK includes improvements to the original Scratchbox2 environment: patches

to fix existing bugs, toolchains for new target architectures, plugin for integration with

both the Eclipse [5] and the Anjuta [3] IDEs, etc. Evidence also made some modifications

to the original environment, in order to let it capable of supporting new architectures.

Last but not least, Evidence provides technical support for its environment.

1.2 Technical features

Evelin SDK has the following technical features:

• Based on the Scratchbox2 [2] project;

• Easy-to-use installer;

• Additional Scratchbox2 scripts;
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Chapter 1. Introduction

• Transparent cross-compilation based on GNU gcc [7];

• Target software emulation: cpu-transparency mechanism that allows to execute

target binaries on the host platform through Qemu [4]. Qemu is a generic and

Open Source processor emulator which achieves a good emulation speed by using

dynamic translation. Qemu is automatically invoked by the environment when

needed (i.e., no intervention of the user is needed). Note that Evelin SDK uses a

proprietary version of Qemu with better support for big-endian targets [8];

• GUI based on the well-known Eclipse IDE [5], with:

– CDT [1] plugin for development of C and C++ programs;

– Proprietary plugin for Scratchbox2 integration;

– Graphical debugging of both host and target binaries.

• Anjuta plugin for Scratchbox2 integration (available only on some distributions).

Anjuta is a development environment made by the Gnome community, which

integrates with Glade-3 [6] for development of GTK-based graphical applications;

• Support for the following targets:

– ARM7

– ARM9 little-endian and big-endian

– ARM11

– Renesas SH4
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2 Installation

2.1 Requirements

In order to install the development environment, a PC with the following characteristics

is required:

• Ubuntu or Debian 32-bit Linux distribution installed;

Note 2.1.1: Currently, the following distributions are supported:

– Ubuntu 8.04 (“Hardy”)

– Ubuntu 8.10 (“Intrepid”)

– Ubuntu 9.04 (“Jaunty”)

– Debian 5.0 (i.e., “Lenny stable” or “Lenny testing”)

Note 2.1.2: Evelin SDK Full includes an image that can be run on any operating

system supporting VMWare.

• 1 GB of free space on the hard disk plus 2.5 GB for each user who will use the

environment;

• bash, apt-get, dpkg, and gzip utilities already installed;

Note 2.1.3: If bash is not installed, just type

apt-get update; apt-get install bash

with superuser permissions (i.e., as root user, or using the sudo command).

Note 2.1.4: On Debian, these tools are automatically installed if the Desktop

environment and Standard system options are selected during the installation of

the operating system.

• /proc and /proc/sys filesystems mounted;

• A Linux kernel with the binfmt misc module (required for the CPU-transparency

mechanism) loaded (as a loadable kernel module or built in the kernel image).
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Chapter 2. Installation

Note 2.1.5: For the supported Linux distributions this is already available on the

default kernel.

Note 2.1.6: If it is not available, you need to recompile the kernel in order to add

this support.

2.2 Installation of the SDK

Most of Evelin SDK is installed inside the user’s home directory. Therefore, the instal-

lation must be done for every user who wants to use the environment.

To start the installation of Evelin SDK follow the next steps:

1. Check to have a working network connection on your host machine.

Note 2.2.1: If your host platform is behind a firewall or a proxyweb, the instal-

lation may fail, because the Ubuntu or Debian repositories may be unreachable.

Please, check this condition with your network administrator.

Note 2.2.2: In case of very slow network connection the installation may fail,

because the apt-get utilities may experience a timeout.

Note 2.2.3: On Ubuntu machines the universe repositories must be enabled in

the /etc/apt/sources.list file. On Debian machines, instead, the non-free

repositories must be enabled. If disabled, the installation script will enable those

repositories automatically, depending on your Linux distribution.

2. Enter the directory containing the Evelin SDK distribution (typically, the CD-

ROM)

3. Read the license in the COPYRIGHT file

4. Start the installation by typing

sudo bash install.sh [<targets>]

as shown in Figure 2.1.

Enter your password, if required.
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Chapter 2. Installation

Figure 2.1: How to install Evelin SDK.

Note 2.2.4: The sudo command requires the user to belong to some specific

groups (e.g., admin or sudo) on the Linux machine. If your user does not have

permissions for using the sudo command, just follow the next steps:

a) Enter as root user by typing su

b) Enter root’s password and press Enter

c) Edit the /etc/sudoers file and add the following line:

<username> ALL=(ALL) ALL

d) Type exit

e) Then, start the installation as specified above

Note 2.2.5: <targets> is the list of targets (e.g., armle, armeb, arm7, arm11,

sh4, etc.) to be installed.

Note 2.2.6: Type install.sh --help to have the list of available targets.

Note 2.2.7: If called without arguments, the install.sh script will install all

available targets.

5. Type accept if you accept the license (otherwise Evelin SDK will not be installed).

6. Accept Java license by Sun (the environment needs Java to run Eclipse)

7. Wait for the EVELIN SDK INSTALLED message.

Note 2.2.8: If you are using the Gnome desktop manager, and if your Linux

distribution is fully supported, some icons will appear on your desktop. Do not
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Chapter 2. Installation

worry if the icons do not appear, since the environment can be easily used also

without them.

8. Reboot the machine in order to make the system read the new settings.

Note 2.2.9: The installation tries to detect your Linux distribution automatically.

However, if not detected, or detected wrongly, the installation program will ask you the

right Linux distribution installed on your host machine. In this case, the user must

specify a Linux distribution between those present in the distro/ directory.

Note 2.2.10: The installation configuration for a given target is written in the

targets/<target>/target.conf configuration file. Do not change the values unless

you really know what you are doing!

Note 2.2.11: If a copy of the environment is already installed, the installation will auto-

matically remove it. Please notice that the content of the rootfs (i.e., ∼/ev-sdk/rootfs/...)

directories will be lost.

Note 2.2.12: Since most of the environment is provided as source code, the installa-

tion requires some time (up to 1 hour, depending on your host hardware and network

connection) to compile the source code.

Note 2.2.13: If the installation is interrupted for some reason (e.g., lack of Internet

connection) restart the installation with the same command specified above.

Note 2.2.14: The version of the SDK installed will be saved into the

∼/ev-sdk/ev-sdk.version file.

Note 2.2.15: Any error during the installation will be saved in the ∼/.ev-sdk.log
file.

Note 2.2.16: Most of the environment will be installed in the ∼/ev-sdk/ directory

2.3 VMWare image

Evelin SDK is available also as VMWare [10] image based on Ubuntu [9]. On this image,

the environment is already installed and configured, so there is no need of installing it.

The VMWare image is compressed as 7-zip archive, and it is located in the vmware/ di-

rectory. A free client to extract the archive can be downloaded from http://www.7-zip.org.

In order to use the vmware image, follow the next steps:
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Chapter 2. Installation

1. Download the vmplayer from http://www.vmware.com/products/player/

2. Install vmplayer

3. Download the 7-zip file archiver from http://www.7-zip.org

4. Install the 7-zip file archiver

5. Extract the vmware/evelin-sdk.7z archive using the 7-zip file archiver. This will

create a directory called evelin-sdk

6. Run vmplayer. A dialog similar to the one shown in Figure 2.2 will appear.

7. Click on Open, and locate the .vmx image inside the evelin-sdk directory

8. The first time you run the image, a dialog similar to the one shown in Figure 2.3

will appear. Click on I copied it.

9. At this point the boot of the Ubuntu image will start

10. Login using user as both login and password

11. Finally, run Evelin SDK as explained in the following chapters.

Figure 2.2: Initial dialog of VMWare.
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Chapter 2. Installation

Figure 2.3: Starting VMWare.

2.4 Removing the environment

If you ever want to remove the SDK from the host machine, just type:

sudo ev-sdk-uninstall

and type your password if asked. Then, wait the EVELIN SDK UNINSTALLED message.
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3 Usage from shell

This section explains how to use the main commands of Evelin SDK. The path of the

commands is automatically appended to user’s ∼/.bashrc file during the installation.

3.1 Entering the environment

• Type sb2-config -l to know the list of available targets

• Type sb2-config -d <target> to set the default target

• Type sb2 to enter the Scratchbox environment using the default target:

– To exit the environment, just type exit

– You can also specify a specific target, using

sb2 -t <target>

• Type sb2 <command> to execute a command inside Scratchbox using the default

target:

– This command runs the given command inside Scratchbox, without the need

of entering the environment

– You can also specify a specific target, using

sb2 -t <target> <command>

3.2 Compiling and building a project

Once entered the environment as explained in the previous section, you can run the

typical commands (i.e., gcc, make, etc.) to build your application. Depending on the

chosen target, Evelin SDK will invoke the right toolchain and will build the application

for such target. In other words, the application can be compiled in the common way as

if we were compiling it for our host architecture: Evelin SDK will do the rest for us.
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3.3 Running a compiled binary

Once the application has been compiled as explained in the previous section, it can be run

on the host architecture, even if the binary has been compiled for a target architecture.

Evelin SDK, in fact, remembers which target the application has been compiled for, and

automatically starts Qemu to run your application! This way, it is possible to run and

debug applications compiled for an embedded microcontroller directly on the host PC.

Note 3.3.1: When using Eclipse, do not use the environment from shell, otherwise the

commands from shell may interfere with Eclipse settings.
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4 Usage from Eclipse

This section explains how to use the GUI based on the Eclipse IDE [5] provided with

the SDK.

4.1 Requirements

In order to run the development environment, a Java 1.6 virtual machine is needed. This

means that the package sun-java6-jre must be installed.

The installation script will try to install the virtual machine automatically from the

repositories.

4.2 Running the GUI

To start the GUI, type ev-sdk-eclipse (without any parameter) on a X11 terminal.

Alternatively, if an icon Evelin SDK Eclipse has been created at installation time on

your desktop, just click the icon.

Note 4.2.1: The installer creates a default workspace located in the /home/<username>

/ev-sdk/bin/eclipse-workspace/ directory. In case you reinstall the SDK, the con-

tent of this directory will be moved to the /home/<username>/ev-sdk/bin/eclipse-

workspace.old/ directory.

4.3 Basic usage

4.3.1 Disabling automatic build

We strongly suggest to disable the automatic building of the project, by clicking on the

Project menu and disabling (i.e., uncheck) the related item, as shown in Figure 4.1.
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Chapter 4. Usage from Eclipse

Figure 4.1: Disabling automatic build.

4.3.2 Visible/hidden windows

The list of visible/hidden windows can be easily changed at any time by clicking on

Window → Show View as shown in Figure 4.2.

Therefore, if at some time you cannot see a window anymore, just click on this menu

to make the window visible.

Figure 4.2: Setting visible/hidden windows.
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4.3.3 Eclipse perspectives

Eclipse has a set of views, called “perspectives”. Each perspective allows to make certain

operations or see certain kind of information.

To change perspective, just click on the icons on the top right corner of the main

window, as shown in Figure 4.3.

Figure 4.3: Changing perspective.

Note 4.3.1: The list of running processes (shown in Figure 4.27) can be seen at any

time by entering the Debug perspective.
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4.3.4 Scratchbox path

To change the Scratchbox path click on Window → Preferences as shown in Figure 4.4.

Then, click on Scratchbox2 Preferences as shown in Figure 4.5.

Note 4.3.2: The default path should be fine in most situations.

Figure 4.4: Scratchbox preferences

Figure 4.5: Changing Scratchbox path.
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4.4 Building existing firmware

Some versions of Evelin SDK (e.g., the version for Xflar) are provided with firmware for

a specific board. This firmware is called “Evelin BSP”.

To build the firmware for your embedded board (if any) follow the operations described

in the next paragraphs.

4.4.1 Import of the project

First of all, disable automatic build of the project as explained in Section 4.3.1.

Then, import the project:

1. Start Eclipse as described in Section 4.2

2. Click on File → Import as shown in Figure 4.6

3. Select General → Existing Projects into Workspace as shown in Figure 4.7

4. Click on Browse to select the root directory as shown in Figure 4.8

5. Select the /home/<user>/ev-sdk/bin/exlipse-workspace directory shown in

Figure 4.9

6. Finally, check the evelin-bsp directory and click Finish as shown in Figure 4.10
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Figure 4.6: Import of the project (Step 1).

Figure 4.7: Import of the project (Step 2).
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Figure 4.8: Import of the project (Step 3).

Figure 4.9: Import of the project (Step 4).
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Figure 4.10: Import of the project (Step 5).
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4.4.2 Building the firmware

To build the firmware, click with the right key of the mouse on the project name inside

the left frame, as shown in Figure 4.11. Then, select Build Project.

Figure 4.11: Building the project.
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4.5 New projects

4.5.1 Creating a new project

To create a new project, follow the next steps:

1. Click on File → New → Project as shown in Figure 4.12.

2. Select C → New Scratchbox2 project as shown in Figure 4.13.

3. Specify the project name.

4. Select the default target, as shown in Figure 4.14.

Note 4.5.1: This allows to specify for which target the binary will be compiled

for. Host refers to the host architecture.

Note 4.5.2: If you wish, you can choose to start from an existing template which

shows how to write the Makefile (strongly recommended).

Note 4.5.3: The default path is taken from the dialog shown in Figure 4.4 and

should be fine in most situations.

Figure 4.12: Creating a new project on Eclipse.
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Figure 4.13: Creating a Scratchbox project on Eclipse.

Figure 4.14: Choosing Scratchbox path and default target.
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4.5.2 Target selection

To change the target for a given project, click with the right button of the mouse on

the project, and select Properties as shown in Figure 4.15.

Then, click on Scratchbox2 Options as shown in Figure 4.16.

Note 4.5.4: This allows to specify for which target the binary will be compiled for.

Note 4.5.5: Host refers to the host architecture.

Choose the target, then click on Apply and then on OK.

Figure 4.15: Project properties.
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Figure 4.16: Changing target for a given project.
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4.5.3 Building the project

Before building the project, disable automatic build of the project as explained in

Section 4.3.1.

Then, to build the project, click with the right key of the mouse on the project name

inside the left frame, as shown in Figure 4.11. Select Clean Project followed by Build

Project.
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4.5.4 Running the application

To run the application, follow the next steps:

1. Select your target as explained in Section 4.5.2

2. Build the project as explained in Section 4.5.3

3. Click the Run icon as shown in Figure 4.17 and select the Run configurations . . .

item.

4. The first time you run the application you have to create the configuration. To do

that, click twice on the Scratchbox2 application item as shown in Figure 4.18. A

new configuration for your application will appear, as shown in Figure 4.19.

5. Select the project you wish to run in the Project box.

6. Select the project you wish to run in the C/C++ Application box.

Note 4.5.6: It would not be possible to select the project if it has not been already

compiled.

7. Click the Run button.

8. To terminate the application, click the icon shown in Figure 4.20.

Note 4.5.7: The application can be run even if compiled for a target different than the

host machine: Evelin SDK will automatically detect the type of binary and will start

Qemu to run the application.

Note 4.5.8: The list of running processes (shown in Figure 4.27) can be seen at any

time by entering the Debug perspective.
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Figure 4.17: Running a project.

Figure 4.18: Configuration for running a project.

33



Chapter 4. Usage from Eclipse

Figure 4.19: Configuration for running a project (2).

Figure 4.20: How to terminate a running application.
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4.5.5 Debugging the application

Eclipse provides a GUI to debug your application using an internal gdb. Internally, the

debug works as a client-server remote debugging: the Eclipse gdb client connects to the

Qemu gdb server which runs the application. The communication between client and

server is made through a network port of the host machine.

To debug the application, follow the next steps:

1. First of all, edit the Makefile of the project and add the -g option to gcc parame-

ters. This option compiles the project adding all symbolic information needed for

debugging. Usually the option is appended to the CFLAGS variable.

2. Save the Makefile

3. Select your target as explained in Section 4.5.2

4. Build the project as explained in Section 4.5.3

5. Click the Debug icon as shown in Figure 4.21 and select the Debug configurations . . .

item.

6. The first time you debug the application you have to create the configuration. To

do that, click twice on the Scratchbox2 application item as shown in Figure 4.22.

A new configuration for your application will appear, as shown in Figure 4.23.

7. Select the project you wish to debug in the Project box.

8. Select the project you wish to debug in the C/C++ Application box.

Note 4.5.9: It would not be possible to select the project if it has not been already

compiled.

9. The Debugger tab shown in Figure 4.24 allows to set the network port of the

operating system used for debugging. The default value is 1234. You can change

this value according to your needs.

Note 4.5.10: This feature allows to debug more applications simultaneously, by

using a different port for each debugged application.

Note 4.5.11: See the /etc/services file to know which ports are already used

by other applications.
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10. Click the Debug button

11. The first time you start a debugging session, the window shown in Figure 4.25 will

appear. Check the combobox and press the Yes button.

Note 4.5.12: Debugging on some targets is not yet supported. For those targets,

the window shown in Figure 4.26 will appear.

12. At this point the window shown in Figure 4.27 will appear. Refer to Eclipse

documentation for information about how debug your application. Figure 4.28

briefly shows some of the features about debugging offered by the interface.

13. To terminate the application, click the icon shown in Figure 4.29.

14. To return to the C/C++ perspective, click the icon on the top right corner of the

window, shown in Figure 4.30.

Note 4.5.13: The application can be debugged even if compiled for a target different

than the host machine: Evelin SDK, in fact, remembers which target the application has

been compiled for, and automatically starts Qemu to debug your application! This way,

it is possible to run and debug applications compiled for an embedded microcontroller

directly on the host PC.

Figure 4.21: Debugging a project.
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Figure 4.22: Creating the configuration for debugging a project.

Figure 4.23: Creating the configuration for debugging a project (2).
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Figure 4.24: Changing the port used for debugging.

Figure 4.25: Changing perspective to Debug.

Figure 4.26: Debugging on unsupported target.
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Figure 4.27: Debug running.

Figure 4.28: Debug features.

Figure 4.29: Terminating a debugged application.
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Figure 4.30: Changing perspective to C/C++.
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5 Usage from Anjuta

On some recent distributions, the installer adds also some basic support integrated with

the Anjuta IDE [3]. This section explains how to enable and configure this support.

Note 5.0.14: Currently, this feature is supported only on Ubuntu 8.10 (“Intrepid”) and

Ubuntu 9.04 (“Jaunty”).

5.1 Running the GUI

To start the GUI, type anjuta (without any parameter) on a X11 terminal. Alter-

natively, if an icon Evelin SDK Anjuta has been created at installation time on your

desktop, just click the icon.

5.2 Configuration of the plugin

The first time you start Anjuta, you must configure the plugin as follows:

1. Click Edit → Preferences as shown in Figure 5.1

2. Click the Installed plugins tab shown in Figure 5.2

3. Enable the Scratchbox plugin

Note 5.2.1: If this plugin is missing, it means that the development is not yet

supported under Anjuta on your distribution. In this case, use Eclipse for devel-

opment.

4. A series of warnings will appear on the screen. They just inform that the plugin

has been enabled but it is not yet configured. Just click OK.

5. Click on the Scratchbox icon that has appeared on the left column. A dialog

to configure the plugin will appear on the right side of the window, as shown in

Figure 5.3
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6. Select Sbox2 in the Scratchbox version menu

7. Select the /home/<username>/ev-sdk/bin/scratchbox directory in the Scratch-

box directory menu

8. Then, select your target in the Scratchbox target menu

9. At this point the plugin is properly configured and will be automatically used by

Anjuta during the development

Figure 5.1: Changing preferences in Anjuta.
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Figure 5.2: Enabling the plugin in Anjuta.

Figure 5.3: Configuring the plugin in Anjuta.
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5.3 How to create a GTK+ project

To create a new project based on the GTK+ graphical libraries, follow the next steps.

1. Click on New → Project as shown in Figure 5.4

2. The dialog shown in Figure 5.5 will appear. Click on Forward.

3. Select GTK+ as shown in Figure 5.6 and click on Forward.

4. Fill the information about the new project as shown in Figure 5.7. Then click on

Forward.

5. The dialog shown in Figure 5.8 will appear. Click on File System. A menu similar

to the one shown in Figure 5.9 will appear. Click on Other....

6. A window similar to the one shown in Figure 5.10 will appear. Click on the Create

Folder button. Then type the folder name as shown in Figure 5.11. Finally, select

the folder just created as shown in Figure 5.12 and click on Open.

7. The summary shown in Figure 5.13 will appear. Click on Apply to create the

project.
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Figure 5.4: How to create a new project.

Figure 5.5: Initial dialog for project creation.
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Figure 5.6: How to create a GTK+ project.

Figure 5.7: Dialog to set project basic information.
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Figure 5.8: Dialog for project options.

Figure 5.9: How to set project location.
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Figure 5.10: How to set project location (2).

Figure 5.11: How to create a new folder for the project.
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Figure 5.12: How to select the folder of the project.

Figure 5.13: Final dialog for project creation.
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5.4 How to draw the GUI of your project

After the project has been created as explained in Section 5.3, to draw the graphical

interface, follow the next steps:

1. Click on the Project tab at the bottom left corner of the window

2. Click twice on the file having glade extension as shown in Figure 5.14

3. The first time you open a glade file, the dialog shown in Figure 5.15 will appear.

Check the checkbox and click on Glade interface designer as shown in the Figure.

4. Click on the Palette tab at the bottom left corner of the window

5. A window similar to the one shown in Figure 5.16 will appear. Use drag-and-drop

to select the items and to add the items to the interface.

Figure 5.14: How to locate the file containing the GUI.
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Figure 5.15: Dialog to select how to view glade files.

Figure 5.16: Dialog to draw the project GUI.
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5.5 How to build your project

To compile your project, follow the next steps.

1. Click on Build → Remove Configuration as shown in Figure 5.17

2. Click Edit → Preferences as shown in Figure 5.1

3. Click the Scratchbox icon on the left column. A dialog to configure the plugin will

appear on the right side of the window, as shown in Figure 5.3

4. Select your target in the Scratchbox target menu and close the dialog

5. Click on Build → Build Project as shown in Figure 5.18.

Figure 5.17: How to clean the project before building.
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Figure 5.18: How to build the project.
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6 Known issues

This section contains the list of known issues. Please, check this list before sending any

help request to the technical support services.

6.1 Installation

Note 6.1.1: Evelin SDK does not work on Ubuntu 8.04 under vmware. Please, use a

more updated image of Ubuntu (e.g. 8.10) from the website http://chrysaor.info

6.2 Usage
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